12+  Свидетельство СМИ ЭЛ № ФС 77 - 70917
Лицензия на образовательную деятельность №0001058
Пользовательское соглашение     Контактная и правовая информация
 
Педагогическое сообщество
УРОК.РФУРОК
Материал опубликовал
Макарова Светлана Александровна665
Учитель физики и информатики
Россия, Свердловская обл., Ревда

Встроенные функции. Использование встроенных функций

Встроенные функции

В поставку EXCEL 2003 входит более 300 функций. Используя VBA можно создавать свои функции. Формат стандартной функции: Имя_Функции (Аргумент) Аргументом может быть: 1. Пустой аргумент () - СЕГОДНЯ(). 2. Константа - КОРЕНЬ(124). 3. Ссылка на ячейку (адрес) - КОРЕНЬ(А4). 4. Диапазон - СУММ(А3:А8). 5. Несколько аргументов - а) фиксированное число - ОКРУГЛ(123,4565; 2) = 123,46. б) неопределенное число (до 30) - СРЗНАЧ(А5:В8; D5:E8; F12; 125). 6. Выражения - КОРЕНЬ(A1^2+A2^2). 7. Другие функции - SIN(РАДИАНЫ(В2)).

Название Назначение Действие 1. Математические – 50 штук 1. ЦЕЛОЕ Определяет целую часть числа =ЦЕЛОЕ(412,98) –412 2. СЛЧИС Определяет случайное число из [0,1) =ЦЕЛОЕ(6*СЛЧИС()+1) – опр. случайное число от 1 до 6 3. РИМСКОЕ Преобразует число римское =РИМСКОЕ(1998) –MCMXCVIII 4. ОКРУГЛ Округляет значение до указанного количества десятичных разрядов =ОКРУГЛ(123,456; 2) – 123,46 =ОКРУГЛ(123,456; 1) – 123,50 =ОКРУГЛ(123,456; -2) – 100,00 5. ПИ Число p – 14 знаков 6.SIN Sin угла в радианах 7. КОРЕНЬ Квадратный корень Кубический корень – ^1/3 =КОРЕНЬ (А4+В4) 8.СУММ Вычисляет сумму – до 30 аргументов кнопка <S> =СУММ(А1:А7; В1:В7; Е7; С12)

2. Статистические – 80 шт. 1. СРЗНАЧ Определяет среднее значение =СРЗНАЧ(А1:А12; С1:С12) 2. МИН Определяет наименьшее знач. =МИН(А3:С3; А8:С8) 3. МАКС Определяет наибольшее знач. =МАКС(А3:С3; А8:С8) 3. Дата и время – 14 шт. 1. СЕГОДНЯ Вставляет сегодняшнюю дату =СЕГОДНЯ() 2. ДЕНЬНЕД Определяет день недели указанной даты =ДЕНЬНЕД(Дата; код) =ДЕНЬНЕД (СЕГОДНЯ();1) 3. ДЕНЬ Выделяет день месяца из указанной даты =ДЕНЬ(12.09.2006) – 12 =ДЕНЬ(СЕГОДНЯ()) 3. МЕСЯЦ Выделяет месяц =МЕСЯЦ(12.09.2002) –9 3. ГОД Выделяет год =год(12.05.2006) – 2006

Задачи Категория “Математическая”

Категория “Статистическая”